Intermittent Login/Performance Issues with Skedula
Incident Report for IO Education
Resolved
This incident has been resolved.
Posted Oct 10, 2019 - 17:52 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 10, 2019 - 12:58 PDT
This incident affected: PupilPath and Skedula.