PupilPath Slow Sign In Times
Incident Report for IO Education
Resolved
This incident has been resolved.
Posted Nov 15, 2019 - 07:34 PST
Update
We are continuing to investigate this issue.
Posted Nov 15, 2019 - 07:33 PST
Update
We are continuing to investigate this issue.
Posted Nov 15, 2019 - 07:31 PST
Investigating
We are investigating the slow sign in times
Posted Nov 15, 2019 - 06:32 PST
This incident affected: PupilPath and Skedula.