Users Cannot Login to Skedula / PupilPath
Incident Report for IO Education
Resolved
This incident has been resolved.
Posted Oct 07, 2019 - 13:37 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 07, 2019 - 12:28 PDT
Investigating
We are currently investigating this issue.
Posted Oct 07, 2019 - 12:02 PDT
This incident affected: PupilPath and Skedula.