IO Classroom Degraded Application Performance
Incident Report for IO Education
Resolved
This incident has been resolved.
Posted Oct 15, 2019 - 13:40 PDT
Investigating
The engineering team is investigating reports of slow performance in both PupilPath and Skedula applications.
Posted Oct 15, 2019 - 12:18 PDT
This incident affected: PupilPath and Skedula.