Users Unable to Login to Skedula
Incident Report for IO Education
Resolved
This incident has been resolved.
Posted Oct 08, 2019 - 14:59 PDT
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 08, 2019 - 12:32 PDT
Investigating
We are currently investigating this issue.
Posted Oct 08, 2019 - 12:19 PDT
This incident affected: PupilPath and Skedula.